Buscar

Cargando...

viernes, 14 de mayo de 2010

Búsqueda en una tabla de doble entrada

Para ver la versión interactiva de Excel Mashup: Excel Mashup: Búsqueda en una tabla de doble entrada II.

Un problema muy frecuente es el de realizar una búsqueda con dos criterios en una tabla de doble entrada. Por suerte, Excel ofrece muchas alternativas para llevar esto a cabo.

En el archivo van algunas ideas para realizar dichas búsquedas con fórmulas, algunas funcionan muy bien para la gran mayoría de los casos, otras sólo en caso de que los datos al interior de la tabla sean numéricos, otras requieren de nombres definidos, etc.

Buscar con dos parámetros.xls

Estructura de los datos
BCDEFGHIJKL
4Columna1Columna2Columna3Columna4Columna5Columna6Columna7Columna8Columna9Columna10
5Fila10,581956470,023086220,969155490,575497490,072821970,164831160,3007602010,871589410,179954090,90422252
6Fila20,807135290,612407270,420764570,102584940,140650680,652996790,4366661540,276692170,748771610,2645273
7Fila30,078815680,334479680,112952610,420361290,34570910,048780220,6866206490,284377880,959297220,02896422
8Fila40,954769750,783492430,117982080,254319930,924402270,178217550,1819476080,469362390,980964720,08172721
9Fila50,339003950,271424530,237932170,023862090,35530720,872195990,8832728540,04622090,550853540,92367039
10Fila60,212813090,789838520,731695330,17221760,419757090,136499210,2852305110,814176330,692484510,61449292
11Fila70,307051610,334640430,9229710,04176850,71440450,320953380,2690712890,575787530,138617760,61712884
12Fila80,317660160,231855270,962878560,91799610,20453030,766036060,1584453220,296737990,178382650,45563426
13Fila90,449862950,291589990,568218130,219376490,72417980,47437550,6867554680,839594120,604321420,92421154
14Fila100,946430510,582927590,824950840,375690350,385611980,847018640,8229381590,243208020,744775660,29698415

Formulas para buscar con dos criterios
CeldaFormula
C20=INDICE(C5:L14,,COINCIDIR(C19,C4:L4,0)) INDICE(C5:L14,COINCIDIR(B20,B5:B14,0),)
C22=INDIRECTO(DIRECCION(COINCIDIR(B20,B$1:B14,0),COINCIDIR(C19,$A4:L4,0)))
C24=INDICE(C5:L14,COINCIDIR(B20,B5:B14,0),COINCIDIR(C19,C4:L4,0))
C26=DESREF(B4,COINCIDIR(B20,B5:B14,0),COINCIDIR(C19,C4:L4,0),1,1)
C28=MAX(INDICE((B5:B14=B20)*(C4:L4=C19)*C5:L14,0,0))
C30=SUMAPRODUCTO((C4:L4=C19)*(B5:B14=B20)*C5:L14)
C32=BUSCARV(B20,B5:L14,COINCIDIR(C19,B4:L4),0)
C34{=MAX((B5:B14=B20)*(C4:L4=C19)*C5:L14)}
C36=INDIRECTO(B20) INDIRECTO(C19)
Tenga en cuenta el separador de argumentos de acuerdo con la configuración regional de su equipo.
Los
{ } se obtienen confirmando la fórmula con Ctrl+Mayus+Intro (Ctrl+Shift+Enter).

Seguro hay más soluciones, así que si alguien desea complementar con alguna otra idea ¡pues bienvenido!